epiphany-3.22.7.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit flag-o-matic eutils gnome2 virtualx
  6. DESCRIPTION="GNOME webbrowser based on Webkit"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/Web"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. IUSE="test"
  11. KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86"
  12. COMMON_DEPEND="
  13. >=app-crypt/gcr-3.5.5:=
  14. >=app-crypt/libsecret-0.14
  15. >=app-text/iso-codes-0.35
  16. >=dev-libs/glib-2.44.0:2[dbus]
  17. >=dev-libs/libxml2-2.6.12:2
  18. >=dev-libs/libxslt-1.1.7
  19. >=gnome-base/gsettings-desktop-schemas-0.0.1
  20. >=net-dns/avahi-0.6.22[dbus]
  21. >=net-libs/webkit-gtk-2.14.2:4=
  22. >=net-libs/libsoup-2.48:2.4
  23. >=x11-libs/gtk+-3.19.1:3
  24. >=x11-libs/libnotify-0.5.1:=
  25. gnome-base/gnome-desktop:3=
  26. dev-db/sqlite:3
  27. x11-libs/libX11
  28. "
  29. # epiphany-extensions support was removed in 3.7; let's not pretend it still works
  30. RDEPEND="${COMMON_DEPEND}
  31. x11-themes/adwaita-icon-theme
  32. !www-client/epiphany-extensions
  33. "
  34. # paxctl needed for bug #407085
  35. DEPEND="${COMMON_DEPEND}
  36. app-text/yelp-tools
  37. dev-libs/appstream-glib
  38. >=dev-util/intltool-0.50
  39. sys-apps/paxctl
  40. sys-devel/gettext
  41. virtual/pkgconfig
  42. "
  43. PATCHES=(
  44. # https://bugzilla.gnome.org/show_bug.cgi?id=751591
  45. "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
  46. # https://bugzilla.gnome.org/show_bug.cgi?id=751593
  47. "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
  48. )
  49. src_configure() {
  50. # https://bugzilla.gnome.org/show_bug.cgi?id=778495
  51. append-cflags -std=gnu11
  52. gnome2_src_configure \
  53. --enable-shared \
  54. --disable-static \
  55. --with-distributor-name=Gentoo \
  56. $(use_enable test tests)
  57. }
  58. src_test() {
  59. "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
  60. GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
  61. }