libXfont2-9999.ebuild 698 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. XORG_DOC=doc
  5. EGIT_REPO_URI="git://anongit.freedesktop.org/xorg/lib/libXfont"
  6. inherit xorg-2
  7. DESCRIPTION="X.Org Xfont library"
  8. KEYWORDS=""
  9. IUSE="bzip2 ipv6 truetype"
  10. RDEPEND="x11-libs/xtrans
  11. x11-libs/libfontenc
  12. sys-libs/zlib
  13. truetype? ( >=media-libs/freetype-2 )
  14. bzip2? ( app-arch/bzip2 )
  15. x11-proto/xproto
  16. >=x11-proto/fontsproto-2.1.3"
  17. DEPEND="${RDEPEND}"
  18. src_configure() {
  19. XORG_CONFIGURE_OPTIONS=(
  20. $(use_enable ipv6)
  21. $(use_enable doc devel-docs)
  22. $(use_with doc xmlto)
  23. $(use_with bzip2)
  24. $(use_enable truetype freetype)
  25. --without-fop
  26. )
  27. xorg-2_src_configure
  28. }