libfakekey-0.1-r1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit eutils autotools
  5. DESCRIPTION="Helper library for the x11-misc/matchbox-keyboard package"
  6. HOMEPAGE="http://matchbox-project.org/"
  7. SRC_URI="http://matchbox-project.org/sources/${PN}/${PV}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ~hppa ppc x86"
  11. IUSE="debug doc"
  12. RDEPEND="x11-libs/libXtst"
  13. DEPEND="${RDEPEND}
  14. doc? ( app-doc/doxygen )"
  15. src_prepare() {
  16. # Allow configure to use libtool-2
  17. epatch "${FILESDIR}/${P}-ac.patch"
  18. # Fix underlinking bug #367595
  19. sed -i -e 's/^fakekey_test_LDADD=/fakekey_test_LDADD=-lX11 /' \
  20. tests/Makefile.am || die 'Cannot sed Makefile.am'
  21. sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
  22. eautoreconf
  23. }
  24. src_configure() {
  25. # --with/without-x is ignored by configure script and X is used.
  26. econf --with-x \
  27. $(use_enable debug) \
  28. $(use_enable doc doxygen-docs) \
  29. || die "Configuration failed"
  30. }
  31. src_install() {
  32. make DESTDIR="${D}" install || die "Installation failed"
  33. dodoc AUTHORS ChangeLog INSTALL NEWS README
  34. use doc && dohtml doc/html/*
  35. }