kbdd-0.7.1.ebuild 587 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils vcs-snapshot
  5. DESCRIPTION="Very simple layout switcher"
  6. HOMEPAGE="https://github.com/qnikst/kbdd"
  7. SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="dbus"
  12. DEPEND="dev-libs/glib:2=
  13. x11-libs/libX11:0=
  14. dbus? (
  15. sys-apps/dbus:0=
  16. >=dev-libs/dbus-glib-0.86:0=
  17. )
  18. "
  19. RDEPEND="${DEPEND}"
  20. src_prepare() {
  21. eautoreconf
  22. }
  23. src_configure() {
  24. econf $(use_enable dbus)
  25. }