parcellite-1.2.1.ebuild 902 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils fdo-mime
  5. MY_P=${PN}-${PV/_}
  6. DESCRIPTION="A lightweight GTK+ based clipboard manager"
  7. HOMEPAGE="http://parcellite.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="nls"
  13. RDEPEND=">=dev-libs/glib-2.14
  14. >=x11-libs/gtk+-2.10:2"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig
  17. nls? (
  18. dev-util/intltool
  19. sys-devel/gettext
  20. )"
  21. S=${WORKDIR}/${MY_P}
  22. src_prepare() {
  23. sed -i data/${PN}.desktop.in -e 's:Application;::g' || die
  24. sed -i -e '/^ALL_LINGUAS=/d' configure.ac || die
  25. strip-linguas -i po/
  26. export ALL_LINGUAS="${LINGUAS}"
  27. eautoreconf
  28. }
  29. src_configure() {
  30. econf $(use_enable nls)
  31. }
  32. pkg_postinst() {
  33. fdo-mime_desktop_database_update
  34. }
  35. pkg_postrm() {
  36. fdo-mime_desktop_database_update
  37. }