piedock-1.6.6-r1.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A little bit like the famous OS X dock but in shape of a pie menu"
  5. HOMEPAGE="http://markusfisch.de/PieDock"
  6. SRC_URI="http://markusfisch.de/downloads/${P}.tar.bz2
  7. https://github.com/markusfisch/PieDock/commit/a7fda1896f1cc6966ba0fa8912e9b404c1b0be97.patch -> ${P}-gcc6.patch"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gtk kde"
  12. RDEPEND="
  13. media-libs/libpng:0=
  14. x11-libs/libX11
  15. x11-libs/libXft
  16. x11-libs/libXmu
  17. x11-libs/libXrender
  18. gtk? (
  19. dev-libs/atk
  20. dev-libs/glib
  21. x11-libs/gdk-pixbuf
  22. x11-libs/gtk+:2
  23. )
  24. kde? (
  25. kde-frameworks/kdelibs:4
  26. dev-qt/qtcore:4
  27. dev-qt/qtgui:4
  28. )
  29. "
  30. DEPEND="${RDEPEND}"
  31. DOCS=( res/${PN}rc.sample AUTHORS ChangeLog NEWS )
  32. PATCHES=(
  33. "${FILESDIR}"/${PN}-1.6.1-signals.patch
  34. "${DISTDIR}"/${P}-gcc6.patch
  35. )
  36. src_configure() {
  37. econf \
  38. $(use_enable gtk) \
  39. $(use_enable kde) \
  40. --bindir="${EPREFIX}"/usr/bin \
  41. --enable-xft \
  42. --enable-xmu \
  43. --enable-xrender
  44. }