sisctrl-0.0.20051202.ebuild 712 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic
  5. DESCRIPTION="tool that allows you to tune SiS drivers from X"
  6. HOMEPAGE="http://www.winischhofer.net/linuxsispart1.shtml#sisctrl"
  7. SRC_URI="http://www.winischhofer.net/sis/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 x86"
  11. IUSE=""
  12. RDEPEND="dev-libs/glib:2
  13. x11-libs/gtk+:2
  14. x11-libs/libXrender
  15. x11-libs/libXv
  16. x11-libs/libXxf86vm"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. x11-proto/xf86vidmodeproto"
  20. DOCS="AUTHORS ChangeLog NEWS README"
  21. src_prepare() {
  22. epatch "${FILESDIR}"/${P}-no-xv.patch
  23. sed -i -e 's,/X11R6,,g' configure || die
  24. append-flags -lm
  25. }