sselp-0.2.ebuild 732 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs
  4. DESCRIPTION="Simple X selection printer"
  5. HOMEPAGE="http://tools.suckless.org/x/sselp"
  6. SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64 hppa ~ppc ~ppc64 x86"
  10. DEPEND="x11-libs/libX11"
  11. RDEPEND="${DEPEND}"
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. sed -i \
  16. -e "s|^CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall|" \
  17. -e "s|^LDFLAGS = -s|LDFLAGS +=|" \
  18. -e "s|^CC = cc|CC = $(tc-getCC)|" \
  19. config.mk || die "sed failed"
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
  23. dodoc README
  24. }