xnots-0.2.1-r1.ebuild 990 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic toolchain-funcs
  5. DESCRIPTION="A desktop sticky note program for the unix geek"
  6. HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
  7. SRC_URI="mirror://sourceforge/xnots/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="vim-syntax"
  12. RDEPEND="
  13. x11-libs/libX11
  14. x11-libs/libXext
  15. x11-libs/libXrandr
  16. x11-libs/libXrender
  17. x11-libs/pango[X]
  18. "
  19. DEPEND="
  20. ${RDEPEND}
  21. virtual/pkgconfig
  22. x11-proto/randrproto
  23. x11-proto/renderproto
  24. x11-proto/xextproto
  25. "
  26. src_prepare() {
  27. sed -i -e 's|LICENCE||g' Makefile || die
  28. append-cflags -std=gnu89
  29. }
  30. src_compile() {
  31. emake CC="$(tc-getCC)" NO_DEBUG=1
  32. }
  33. src_install() {
  34. emake \
  35. DESTDIR="${D}" \
  36. docdir=/usr/share/doc/${PF} \
  37. mandir=/usr/share/man \
  38. prefix=/usr \
  39. install
  40. if use vim-syntax; then
  41. insinto /usr/share/vim/vimfiles/syntax
  42. doins etc/xnots.vim
  43. fi
  44. }