xplanetFX-2.6.12.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-r1
  6. DESCRIPTION="GUI to configure, run or daemonize xplanet with HQ capabilities"
  7. HOMEPAGE="http://mein-neues-blog.de/xplanetFX/"
  8. SRC_URI="http://repository.mein-neues-blog.de:9000/archive/${P/FX/fx}_all.tar.gz"
  9. LICENSE="WTFPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="libnotify"
  13. DEPEND=""
  14. RDEPEND="${DEPEND}
  15. dev-python/pygtk[${PYTHON_USEDEP}]
  16. media-gfx/imagemagick
  17. sys-devel/bc
  18. x11-misc/xplanet
  19. libnotify? ( x11-libs/libnotify )"
  20. #python
  21. S="${WORKDIR}/usr"
  22. src_prepare() {
  23. default
  24. eapply "${FILESDIR}"/${PN}-2.6.4-gentoo-path.patch
  25. sed -e "s/Application;//" -i share/applications/*desktop || die
  26. # These will be installed separately
  27. mkdir gentoo || die
  28. mv share/${PN}/{autostart,flipview.py,stars/catalog.py,xplanetFX_gtk,xplanetFX_tray} \
  29. gentoo || die
  30. }
  31. src_install() {
  32. dobin bin/${PN}
  33. insinto /usr/share/applications
  34. doins share/applications/${PN}.desktop
  35. insinto /usr/share/pixmaps
  36. doins share/pixmaps/*
  37. insinto /usr/share/${PN}
  38. doins -r share/${PN}/*
  39. exeinto /usr/share/${PN}
  40. doexe gentoo/autostart
  41. dodoc share/doc/${PN}/{changelog,README}
  42. python_scriptinto /usr/share/${PN}/stars
  43. python_foreach_impl python_doscript gentoo/catalog.py
  44. python_scriptinto /usr/share/${PN}
  45. python_foreach_impl python_doscript gentoo/{xplanetFX_gtk,xplanetFX_tray}
  46. python_foreach_impl python_domodule gentoo/flipview.py
  47. }