mlterm-3.4.5.ebuild 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit autotools-utils eutils
  5. DESCRIPTION="A multi-lingual terminal emulator"
  6. HOMEPAGE="http://mlterm.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/mlterm/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa ppc ppc64 x86"
  11. IUSE="bidi cairo debug fcitx gtk ibus libssh2 m17n-lib nls regis scim static-libs uim utempter xft"
  12. RDEPEND="x11-libs/libICE
  13. x11-libs/libSM
  14. x11-libs/libX11
  15. bidi? ( dev-libs/fribidi )
  16. cairo? ( x11-libs/cairo[X] )
  17. fcitx? ( app-i18n/fcitx )
  18. gtk? ( >=x11-libs/gtk+-2:= )
  19. ibus? ( app-i18n/ibus )
  20. libssh2? ( net-libs/libssh2 )
  21. m17n-lib? ( dev-libs/m17n-lib )
  22. nls? ( virtual/libintl )
  23. regis? (
  24. || (
  25. media-libs/sdl-ttf
  26. media-libs/sdl2-ttf
  27. )
  28. )
  29. scim? ( app-i18n/scim )
  30. uim? ( app-i18n/uim )
  31. utempter? ( sys-libs/libutempter )
  32. xft? ( x11-libs/libXft )"
  33. DEPEND="${RDEPEND}
  34. virtual/pkgconfig
  35. nls? ( sys-devel/gettext )"
  36. DOCS=( ChangeLog README doc/{en,ja} )
  37. AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
  38. src_prepare() {
  39. # default config
  40. sed -i \
  41. -e "/ icon_path =/aicon_path = ${EPREFIX}/usr/share/pixmaps/mlterm-icon.svg" \
  42. -e "/ scrollbar_view_name =/ascrollbar_view_name = sample" \
  43. etc/main
  44. autotools-utils_src_prepare
  45. }
  46. src_configure() {
  47. local myeconfargs=(
  48. --with-type-engines=xcore$(usex xft ",xft" "")$(usex cairo ",cairo" "")
  49. --enable-optimize-redrawing
  50. --enable-vt52
  51. $(use_enable bidi fribidi)
  52. $(use_enable debug)
  53. $(use_enable fcitx)
  54. $(use_enable ibus)
  55. $(use_enable libssh2 ssh2)
  56. $(use_enable m17n-lib m17nlib)
  57. $(use_enable nls)
  58. $(use_enable scim)
  59. $(use_enable uim)
  60. $(use_enable utempter utmp)
  61. )
  62. local scrollbars="sample,extra"
  63. local tools="mlclient,mlcc,mlmenu,mlterm-zoom"
  64. if use gtk; then
  65. myeconfargs+=(--with-imagelib=gdk-pixbuf)
  66. if has_version x11-libs/gtk+:3; then
  67. myeconfargs+=(--with-gtk=3.0)
  68. else
  69. myeconfargs+=(--with-gtk=2.0)
  70. fi
  71. scrollbars+=",pixmap_engine"
  72. tools+=",mlconfig,mlimgloader"
  73. fi
  74. if use regis; then
  75. tools+=",registobmp"
  76. fi
  77. myeconfargs+=(--with-scrollbars="${scrollbars}")
  78. myeconfargs+=(--with-tools="${tools}")
  79. addpredict /dev/ptmx
  80. autotools-utils_src_configure
  81. }
  82. src_test() {
  83. :
  84. }
  85. src_install () {
  86. autotools-utils_src_install
  87. docinto contrib/icon
  88. dodoc contrib/icon/README
  89. doicon contrib/icon/mlterm*
  90. make_desktop_entry mlterm mlterm mlterm-icon "System;TerminalEmulator"
  91. }