libxfce4ui-4.12.1-r2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
  6. HOMEPAGE="http://www.xfce.org/projects/libxfce4"
  7. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="LGPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  11. IUSE="debug +gtk3 startup-notification"
  12. RDEPEND=">=dev-libs/glib-2.30:2=
  13. >=x11-libs/gtk+-2.24:2=
  14. x11-libs/libX11:=
  15. x11-libs/libICE:=
  16. x11-libs/libSM:=
  17. >=xfce-base/libxfce4util-4.12:=
  18. >=xfce-base/xfconf-4.12:=
  19. gtk3? ( >=x11-libs/gtk+-3.2:3= )
  20. startup-notification? ( x11-libs/startup-notification:= )
  21. !xfce-base/xfce-utils"
  22. DEPEND="${RDEPEND}
  23. dev-lang/perl
  24. dev-util/intltool
  25. sys-devel/gettext
  26. virtual/pkgconfig"
  27. pkg_setup() {
  28. XFCONF=(
  29. $(use_enable startup-notification)
  30. $(use_enable gtk3)
  31. $(xfconf_use_debug)
  32. # requires deprecated glade:3 (gladeui-1.0), bug #551296
  33. --disable-gladeui
  34. --with-vendor-info=Gentoo
  35. )
  36. [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
  37. DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
  38. }