xfce4-session-4.12.1.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EAUTORECONF=1
  5. inherit xfconf
  6. DESCRIPTION="A session manager for the Xfce desktop environment"
  7. HOMEPAGE="http://docs.xfce.org/xfce/xfce4-session/start"
  8. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  12. IUSE="debug nls policykit systemd upower +xscreensaver"
  13. COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
  14. x11-apps/iceauth
  15. x11-libs/libSM:=
  16. >=x11-libs/libwnck-2.30:1=
  17. x11-libs/libX11:=
  18. >=xfce-base/libxfce4util-4.11:=
  19. >=xfce-base/libxfce4ui-4.12.1:=
  20. >=xfce-base/xfconf-4.10:=
  21. !xfce-base/xfce-utils
  22. !=xfce-base/libxfce4ui-4.12.0
  23. policykit? ( >=sys-auth/polkit-0.102:= )
  24. upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
  25. RDEPEND="${COMMON_DEPEND}
  26. x11-apps/xrdb
  27. nls? ( x11-misc/xdg-user-dirs )
  28. !systemd? ( upower? ( sys-power/pm-utils ) )
  29. xscreensaver? ( || (
  30. >=x11-misc/xscreensaver-5.26
  31. gnome-extra/gnome-screensaver
  32. >=x11-misc/xlockmore-5.43
  33. x11-misc/slock
  34. x11-misc/alock[pam]
  35. ) )"
  36. DEPEND="${COMMON_DEPEND}
  37. dev-util/intltool
  38. sys-devel/gettext
  39. virtual/pkgconfig"
  40. REQUIRED_USE="systemd? ( policykit )"
  41. pkg_setup() {
  42. PATCHES=( "${FILESDIR}"/${PN}-4.10.1-alock_support_to_xflock4.patch )
  43. XFCONF=(
  44. --docdir="${EPREFIX}"/usr/share/doc/${PF}
  45. $(use_enable policykit polkit)
  46. --with-xsession-prefix="${EPREFIX}"/usr
  47. $(xfconf_use_debug)
  48. )
  49. use upower && XFCONF+=( --enable-upower )
  50. DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO )
  51. }
  52. src_install() {
  53. xfconf_src_install
  54. local sessiondir=/etc/X11/Sessions
  55. echo startxfce4 > "${T}"/Xfce4
  56. exeinto ${sessiondir}
  57. doexe "${T}"/Xfce4
  58. dosym Xfce4 ${sessiondir}/Xfce
  59. }