apache-tools-2.2.32.ebuild 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic eutils
  5. DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
  6. HOMEPAGE="https://httpd.apache.org/"
  7. SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  11. IUSE="ssl"
  12. RESTRICT="test"
  13. RDEPEND="=dev-libs/apr-1*
  14. =dev-libs/apr-util-1*
  15. dev-libs/expat
  16. dev-libs/libpcre
  17. kernel_linux? ( sys-apps/util-linux )
  18. ssl? ( dev-libs/openssl:0= )
  19. !<www-servers/apache-2.2.4"
  20. DEPEND="${RDEPEND}
  21. sys-devel/libtool"
  22. S="${WORKDIR}/httpd-${PV}"
  23. PATCHES=(
  24. "${FILESDIR}/${PN}-2.2.20-Makefile.patch"
  25. )
  26. src_configure() {
  27. # Brain dead check.
  28. tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
  29. # Instead of filtering --as-needed (bug #128505), append --no-as-needed
  30. append-ldflags $(no-as-needed)
  31. # econf overwrites the stuff from config.layout.
  32. econf \
  33. --sbindir=/usr/sbin \
  34. --with-z=/usr \
  35. --with-apr=/usr \
  36. --with-apr-util=/usr \
  37. --with-pcre=/usr \
  38. $(use_enable ssl) \
  39. $(usex ssl '--with-ssl=/usr' '')
  40. }
  41. src_compile() {
  42. cd support || die
  43. emake
  44. }
  45. src_install () {
  46. cd support || die
  47. make DESTDIR="${D}" install || die
  48. # install manpages
  49. doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
  50. "${S}"/docs/man/{htcacheclean,rotatelogs,ab,logresolve}.8
  51. # Providing compatiblity symlinks for #177697 (which we'll stop to install
  52. # at some point).
  53. pushd "${D}"/usr/sbin/ >/dev/null || die
  54. for i in *; do
  55. dosym /usr/sbin/${i} /usr/sbin/${i}2
  56. done
  57. popd >/dev/null || die
  58. # Provide a symlink for ab-ssl
  59. if use ssl; then
  60. dosym /usr/sbin/ab /usr/sbin/ab-ssl
  61. dosym /usr/sbin/ab /usr/sbin/ab2-ssl
  62. fi
  63. # make htpasswd accessible for non-root users
  64. dosym /usr/sbin/htpasswd /usr/bin/htpasswd
  65. dosym /usr/sbin/htdigest /usr/bin/htdigest
  66. dodoc "${S}"/CHANGES
  67. }