checkrestart-0.47-r3.ebuild 676 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-single-r1
  6. DESCRIPTION="the sysadmin's rolling upgrade tool"
  7. HOMEPAGE="http://arcdraco.net/checkrestart"
  8. SRC_URI="http://arcdraco.net/~dragon/${P}-sep.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~hppa ~x86"
  12. IUSE=""
  13. RDEPEND="
  14. ${PYTHON_DEPS}
  15. sys-apps/lsb-release
  16. app-portage/portage-utils
  17. sys-process/lsof
  18. "
  19. REQUIRED_USE=${PYTHON_REQUIRED_USE}
  20. S=${WORKDIR}
  21. src_prepare() {
  22. epatch "${FILESDIR}"/${P}-list-comprehension-fix.patch
  23. python_fix_shebang ${PN}
  24. }
  25. src_install() {
  26. dosbin ${PN}
  27. }