checkrestart-0.47-r4.ebuild 713 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-single-r1
  6. DESCRIPTION="the sysadmin's rolling upgrade tool"
  7. HOMEPAGE="http://arcdraco.net/checkrestart"
  8. SRC_URI="http://arcdraco.net/~dragon/${P}-sep.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~hppa ~x86"
  12. IUSE=""
  13. RDEPEND="
  14. ${PYTHON_DEPS}
  15. sys-apps/lsb-release
  16. app-portage/portage-utils
  17. sys-process/lsof
  18. "
  19. REQUIRED_USE=${PYTHON_REQUIRED_USE}
  20. S=${WORKDIR}
  21. src_prepare() {
  22. epatch "${FILESDIR}"/${P}-list-comprehension-fix.patch
  23. epatch "${FILESDIR}"/${P}-cwd.patch
  24. python_fix_shebang ${PN}
  25. }
  26. src_install() {
  27. dosbin ${PN}
  28. }