checksec-1.7.5.ebuild 763 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. MY_PN=${PN}.sh
  6. DESCRIPTION="Tool to check properties of executables (e.g. ASLR/PIE, RELRO, PaX, Canaries)"
  7. HOMEPAGE="https://github.com/slimm609/checksec.sh"
  8. SRC_URI="https://github.com/slimm609/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
  12. IUSE=""
  13. S="${WORKDIR}"/${MY_PN}-${PV}
  14. DOCS=( ChangeLog README.md )
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${PN}-1.7.2-path.patch
  17. sed 's,^pkg_release=false,pkg_release=true,' -i ${PN} || die
  18. }
  19. src_install() {
  20. default
  21. doman extras/man/*
  22. insinto /usr/share/zsh/site-functions
  23. doins extras/zsh/_${PN}
  24. dobin ${PN}
  25. }