conkyforecast-2.24-r1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # upstream broke setup.py to install into /usr/share...
  5. DISTUTILS_SINGLE_IMPL=1
  6. PYTHON_COMPAT=( python2_7 )
  7. inherit distutils-r1
  8. DESCRIPTION="Conky weather forecast script with support for language files"
  9. HOMEPAGE="https://launchpad.net/~conky-companions"
  10. SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
  11. LICENSE="GPL-3"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. RDEPEND="app-admin/conky"
  16. S=${WORKDIR}/src
  17. python_prepare_all() {
  18. sed -i -e "s:pythoncmd=.*$:pythoncmd=${EPYTHON}:" conkyForecast* || die
  19. distutils-r1_python_prepare_all
  20. }
  21. python_install() {
  22. distutils-r1_python_install
  23. python_optimize "${ED%/}"/usr/share/${PN}
  24. }
  25. pkg_postinst() {
  26. elog "You have to define a partner id and registration code for "
  27. elog "the weather.com xoap. You need to copy the template from"
  28. elog "/usr/share/conkyforecast/conkyForecast.config into you account"
  29. elog "as ~/.conkyForecast.config and edit the respective fields."
  30. elog
  31. elog "More details can be found in the README file."
  32. }