123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/eselect.git"
- inherit autotools git-r3 bash-completion-r1
- DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
- HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
- LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-2.5 )"
- SLOT="0"
- IUSE="doc emacs vim-syntax"
- RDEPEND="sys-apps/sed
- || (
- sys-apps/coreutils
- sys-freebsd/freebsd-bin
- app-misc/realpath
- )"
- DEPEND="${RDEPEND}
- doc? ( dev-python/docutils )"
- RDEPEND="${RDEPEND}
- sys-apps/file
- sys-libs/ncurses:0"
- PDEPEND="emacs? ( app-emacs/eselect-mode )
- vim-syntax? ( app-vim/eselect-syntax )"
- src_prepare() {
- eautoreconf
- }
- src_compile() {
- emake
- use doc && emake html
- }
- src_install() {
- emake DESTDIR="${D}" install
- newbashcomp misc/${PN}.bashcomp ${PN}
- dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
- use doc && dohtml *.html doc/*
- # needed by news module
- keepdir /var/lib/gentoo/news
- if ! use prefix; then
- fowners root:portage /var/lib/gentoo/news
- fperms g+w /var/lib/gentoo/news
- fi
- }
- pkg_postinst() {
- # fowners in src_install doesn't work for the portage group:
- # merging changes the group back to root
- if ! use prefix; then
- chgrp portage "${EROOT}/var/lib/gentoo/news" \
- && chmod g+w "${EROOT}/var/lib/gentoo/news"
- fi
- }
|