filewatcher-2.4.6.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="This is a configuration file control system and IDS"
  4. HOMEPAGE="https://sourceforge.net/projects/filewatcher/"
  5. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="~amd64 ~ppc ~x86"
  9. IUSE=""
  10. DEPEND=""
  11. RDEPEND="dev-perl/MailTools
  12. dev-vcs/rcs
  13. virtual/mta"
  14. src_install() {
  15. keepdir /var/lib/filewatcher /var/lib/filewatcher/archive
  16. dosbin filewatcher || die "could not install filewatcher"
  17. doman filewatcher.1 || die "could not install filewatcher manpage"
  18. dodoc Changes README
  19. insinto /etc
  20. doins "${FILESDIR}"/filewatcher.conf || \
  21. die "could not install basic filewatcher config"
  22. }
  23. pkg_postinst() {
  24. elog " A basic configuration has been provided in"
  25. elog " /etc/filewatcher.conf. It is strongly"
  26. elog " recommended that you invoke filewatcher via"
  27. elog " crontab."
  28. elog
  29. elog " 55,25,40 * * * * root /usr/sbin/filewatcher"
  30. elog " --config=/etc/filewatcher.conf"
  31. }