genromfs-0.5.2.ebuild 568 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Create space-efficient, small, read-only romfs filesystems"
  6. HOMEPAGE="http://romfs.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm64 ppc ~ppc64 s390 x86"
  11. IUSE=""
  12. DOCS=( ChangeLog NEWS genromfs.lsm genrommkdev readme-kernel-patch romfs.txt )
  13. src_prepare() {
  14. epatch "${FILESDIR}"/${P}-build.patch
  15. }
  16. src_compile() {
  17. tc-export CC
  18. default
  19. }