haskell-updater-1.2.10.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. CABAL_FEATURES="bin nocabaldep"
  5. inherit eutils haskell-cabal
  6. DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
  7. HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater"
  8. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
  12. IUSE=""
  13. DEPEND=">=dev-lang/ghc-6.12.1"
  14. # Need a lower version for portage to get --keep-going
  15. RDEPEND="|| ( >=sys-apps/portage-2.1.6
  16. sys-apps/pkgcore
  17. sys-apps/paludis )"
  18. src_prepare() {
  19. if use prefix; then
  20. sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \
  21. "${S}/Distribution/Gentoo/Packages.hs" || die
  22. sed -i -e 's,"/","'"${EPREFIX}"'/",g' \
  23. "${S}/Distribution/Gentoo/GHC.hs" || die
  24. fi
  25. }
  26. src_configure() {
  27. cabal_src_configure \
  28. --bindir="${EPREFIX}/usr/sbin" \
  29. --constraint="Cabal == $(cabal-version)"
  30. }
  31. src_install() {
  32. cabal_src_install
  33. dodoc TODO
  34. }