jinit-0.1.12-r1.ebuild 892 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="An alternative to sysvinit which supports the need(8) concept"
  5. HOMEPAGE="http://john.fremlin.de/programs/linux/jinit/"
  6. SRC_URI="http://john.fremlin.de/programs/linux/jinit/download/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="-amd64 ~ppc ~sparc ~x86"
  10. IUSE=""
  11. DEPEND=""
  12. RDEPEND=""
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/${P}-gcc43.patch
  17. }
  18. src_install() {
  19. emake DESTDIR="${D}" install || die "failed emake install"
  20. emake prefix="${D}"/usr/share/doc/${PF}/example-setup install-initscripts \
  21. || die "failed installing example setup"
  22. mv "${D}"/usr/sbin "${D}"/ || die
  23. mv "${D}"/sbin/init "${D}"/sbin/jinit || die
  24. mv "${D}"/sbin/shutdown "${D}"/sbin/jinit-shutdown || die
  25. dodoc AUTHORS ChangeLog NEWS README TODO || die
  26. }