lib_users-0.9-r1.ebuild 758 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  5. inherit python-r1
  6. DESCRIPTION="Checks /proc for libraries being mapped but marked as deleted"
  7. HOMEPAGE="http://schwarzvogel.de/software-misc.shtml"
  8. SRC_URI="http://schwarzvogel.de/pkgs/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="test"
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. DEPEND="${PYTHON_DEPS}
  15. test? ( dev-python/nose[${PYTHON_USEDEP}] )"
  16. RDEPEND="${PYTHON_DEPS}"
  17. src_test() {
  18. python_foreach_impl nosetests --verbosity=2
  19. }
  20. src_install() {
  21. python_foreach_impl python_newscript lib_users.py lib_users
  22. dodoc README TODO
  23. }