mcollective-2.10.3.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. USE_RUBY="ruby21 ruby22 ruby23"
  5. inherit ruby-ng
  6. DESCRIPTION="Framework to build server orchestration or parallel job execution
  7. systems"
  8. HOMEPAGE="http://marionette-collective.org/"
  9. SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. S="${WORKDIR}/all/marionette-collective-${PV}"
  11. LICENSE="Apache-2.0"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE="doc +client"
  15. DEPEND=""
  16. RDEPEND="dev-ruby/stomp"
  17. src_compile() {
  18. einfo "nothing to compile"
  19. }
  20. each_ruby_install() {
  21. cd "marionette-collective-${PV}"
  22. doruby -r lib/*
  23. insinto /usr/share/mcollective
  24. use client && dosbin bin/mco
  25. dosbin bin/mcollectived
  26. if use doc ; then
  27. dohtml -r doc/*
  28. insinto /usr/share/doc/${P}/ext
  29. doins -r ext/*
  30. fi
  31. newinitd "${FILESDIR}"/mcollectived.initd mcollectived
  32. insinto /etc/mcollective
  33. cd etc
  34. for cfg in *.dist ; do
  35. newins "${cfg}" "${cfg%%.dist}"
  36. sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
  37. "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
  38. done
  39. insinto /etc/mcollective/plugin.d
  40. }
  41. pkg_postinst() {
  42. einfo "Mcollective requires a stomp server installed and functioning before"
  43. einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
  44. einfo "any other stomp compatible server should work."
  45. einfo
  46. einfo "It is recommended you read the \'getting started\' guide [2] if this"
  47. einfo "is a new installation"
  48. einfo
  49. einfo "[1] http://activemq.apache.org/"
  50. einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
  51. }