multilog-watch-1.12.ebuild 962 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="Watches a multilog file for irregularities"
  5. HOMEPAGE="http://www.eyrie.org/~eagle/software/multilog-watch/"
  6. SRC_URI="http://archives.eyrie.org/software/system/multilog-watch
  7. http://www.eyrie.org/%7Eeagle/software/multilog-watch/sample.filter"
  8. LICENSE="Artistic GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="dev-lang/perl
  13. virtual/qmail"
  14. src_unpack() {
  15. mkdir "${S}"
  16. cp "${DISTDIR}"/multilog-watch "${S}"
  17. cp "${DISTDIR}"/sample.filter "${S}"
  18. }
  19. src_compile() {
  20. mv multilog-watch multilog-watch.orig
  21. sed -e 's/\/etc\/leland/\/etc\/multilog-watch/' multilog-watch.orig > multilog-watch
  22. /usr/bin/pod2man -s 1 multilog-watch multilog-watch.1
  23. }
  24. src_install() {
  25. dodir /etc/multilog-watch
  26. insinto /etc/multilog-watch
  27. doins sample.filter
  28. dobin multilog-watch || die 'install failed'
  29. doman multilog-watch.1
  30. }