newsyslog-1.1.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="a highly configurable program for managing and archiving log files"
  5. HOMEPAGE="http://www.weird.com/~woods/projects/newsyslog.html"
  6. SRC_URI="ftp://ftp.weird.com/pub/local/${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="alpha ~amd64 hppa ~mips ppc ppc64 ~sparc x86"
  10. IUSE=""
  11. DEPEND="sys-apps/groff"
  12. RDEPEND="virtual/cron
  13. app-arch/gzip"
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. epatch "${FILESDIR}"/newsyslog-html.patch
  18. }
  19. src_compile() {
  20. local myconf="--with-syslogd_pid=/var/run/syslog.pid"
  21. has_version 'app-admin/syslog-ng' \
  22. && myconf="--with-syslogd_pid=/var/run/syslog-ng.pid"
  23. econf \
  24. --with-gzip \
  25. --with-newsyslog_conf=/etc/newsyslog.conf \
  26. ${myconf} || die "econf failed"
  27. emake || die
  28. }
  29. src_install() {
  30. emake \
  31. DESTDIR="${D}" \
  32. catmandir="${T}"/dont-install \
  33. install || die "install failed"
  34. dodoc newsyslog.conf AUTHORS ChangeLog INSTALL NEWS README.* ToDo
  35. }