packagekit-base-1.0.11.ebuild 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. # PackageKit supports 3.2+, but entropy and portage backends are untested
  5. # Future note: use --enable-python3
  6. PYTHON_COMPAT=( python2_7 )
  7. VALA_USE_DEPEND="vapigen"
  8. inherit bash-completion-r1 multilib nsplugins python-single-r1 systemd vala
  9. MY_PN="PackageKit"
  10. MY_P=${MY_PN}-${PV}
  11. DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
  12. HOMEPAGE="http://www.packagekit.org/"
  13. SRC_URI="https://www.freedesktop.org/software/${MY_PN}/releases/${MY_P}.tar.xz"
  14. LICENSE="GPL-2"
  15. SLOT="0/18"
  16. KEYWORDS="~alpha amd64 ~arm ~mips ~ppc ~ppc64 x86"
  17. IUSE="connman cron command-not-found +introspection networkmanager nsplugin entropy systemd test vala"
  18. REQUIRED_USE="
  19. ${PYTHON_REQUIRED_USE}
  20. vala? ( introspection )
  21. "
  22. # While not strictly needed, consolekit is the alternative to systemd-login
  23. # to get current session's user.
  24. CDEPEND="
  25. >=app-shells/bash-completion-2
  26. dev-db/sqlite:3
  27. >=dev-libs/dbus-glib-0.74
  28. >=dev-libs/glib-2.32.0:2[${PYTHON_USEDEP}]
  29. >=sys-auth/polkit-0.98
  30. >=sys-apps/dbus-1.3.0
  31. ${PYTHON_DEPS}
  32. connman? ( net-misc/connman )
  33. introspection? ( >=dev-libs/gobject-introspection-0.9.9[${PYTHON_USEDEP}] )
  34. networkmanager? ( >=net-misc/networkmanager-0.6.4 )
  35. nsplugin? (
  36. >=dev-libs/nspr-4.8
  37. x11-libs/cairo
  38. >=x11-libs/gtk+-2.14.0:2
  39. x11-libs/pango
  40. )
  41. systemd? ( >=sys-apps/systemd-204 )
  42. "
  43. DEPEND="${CDEPEND}
  44. dev-libs/libxslt[${PYTHON_USEDEP}]
  45. >=dev-util/gtk-doc-am-1.11
  46. >=dev-util/intltool-0.35.0
  47. sys-devel/gettext
  48. virtual/pkgconfig
  49. nsplugin? ( >=net-misc/npapi-sdk-0.27 )
  50. vala? ( $(vala_depend) )
  51. "
  52. RDEPEND="${CDEPEND}
  53. >=app-portage/layman-2[${PYTHON_USEDEP}]
  54. >=sys-apps/portage-2.2[${PYTHON_USEDEP}]
  55. entropy? ( >=sys-apps/entropy-234[${PYTHON_USEDEP}] )
  56. !systemd? ( sys-auth/consolekit )
  57. "
  58. S="${WORKDIR}/${MY_P}"
  59. RESTRICT="test"
  60. src_prepare() {
  61. use vala && vala_src_prepare
  62. }
  63. src_configure() {
  64. econf \
  65. --disable-gstreamer-plugin \
  66. --disable-gtk-doc \
  67. --disable-gtk-module \
  68. --disable-schemas-compile \
  69. --disable-static \
  70. --enable-bash-completion \
  71. --enable-man-pages \
  72. --enable-nls \
  73. --enable-portage \
  74. --localstatedir=/var \
  75. $(use_enable command-not-found) \
  76. $(use_enable connman) \
  77. $(use_enable cron) \
  78. $(use_enable entropy) \
  79. $(use_enable introspection) \
  80. $(use_enable networkmanager) \
  81. $(use_enable nsplugin browser-plugin) \
  82. $(use_enable systemd) \
  83. $(use_enable test daemon-tests) \
  84. $(use_enable vala) \
  85. $(systemd_with_unitdir)
  86. #$(use_enable test local)
  87. }
  88. src_install() {
  89. emake DESTDIR="${D}" install
  90. prune_libtool_files --all
  91. dodoc AUTHORS ChangeLog MAINTAINERS NEWS README
  92. if use nsplugin; then
  93. dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
  94. mv "${D}/usr/$(get_libdir)/mozilla/plugins"/* \
  95. "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/" || die
  96. fi
  97. }