passook-20121001.ebuild 667 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils prefix
  5. DESCRIPTION="Password generator capable of generating pronounceable and/or secure passwords"
  6. HOMEPAGE="https://github.com/mackers/passook"
  7. # snapshot of git://github.com/mackers/passook.git
  8. SRC_URI="mirror://gentoo/${P}.tar.gz"
  9. LICENSE="GPL-3+"
  10. SLOT="0"
  11. KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
  12. RDEPEND="dev-lang/perl
  13. sys-apps/miscfiles"
  14. S="${WORKDIR}/${PN}"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/passook.patch
  17. eprefixify passook
  18. }
  19. src_install() {
  20. dobin passook
  21. dodoc README passook.cgi
  22. }