procinfo-ng-2.0.304-r1.ebuild 929 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils toolchain-funcs
  5. DESCRIPTION="Completely rewrite of the old system monitoring app procinfo"
  6. HOMEPAGE="https://sourceforge.net/projects/procinfo-ng/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
  8. LICENSE="|| ( GPL-2 LGPL-2.1 )"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa x86"
  11. IUSE=""
  12. RDEPEND="
  13. sys-libs/ncurses
  14. !app-admin/procinfo"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. PATCHES=(
  18. "${FILESDIR}"/${P}-as-needed.patch
  19. "${FILESDIR}"/${P}-man.patch
  20. )
  21. src_prepare() {
  22. epatch "${PATCHES[@]}"
  23. # removing -s flag as portage does the stripping part and add support
  24. # for custom LDFLAGS. Plus correct for --as-needed
  25. sed \
  26. -e 's:-s -lncurses:${LDFLAGS}:' \
  27. -i configure.in || die "sed configure.in failed"
  28. eautoreconf
  29. }
  30. src_compile() {
  31. emake LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
  32. }