restart_services-0.13.0-r1.ebuild 942 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Tool to manage OpenRC services that need to be restarted"
  5. HOMEPAGE="https://dev.gentoo.org/~mschiff/restart_services/"
  6. SRC_URI="https://dev.gentoo.org/~mschiff/src/${PN}/${P}.tgz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE=""
  11. DEPEND=""
  12. RDEPEND="
  13. app-admin/lib_users
  14. sys-apps/openrc
  15. "
  16. src_install() {
  17. dosbin restart_services
  18. doman restart_services.1
  19. keepdir /etc/restart_services.d
  20. insinto /etc
  21. doins restart_services.conf
  22. dodoc README CHANGES
  23. sed -i 's/^#include/include/' "${D}"/etc/restart_services.conf
  24. cat>"${D}"/etc/restart_services.d/00-local.conf<<-EOF
  25. # You may put your local changes here or in any other *.conf file
  26. # in this directory so you can leave /etc/restart_services.conf as is.
  27. # Example:
  28. # *extend* SV_ALWAYS to match 'myservice'
  29. # SV_ALWAYS+=( myservice )
  30. EOF
  31. }