supervisor-3.2.2.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 ) # py2 only
  5. # xml.etree.ElementTree module required.
  6. PYTHON_REQ_USE="xml"
  7. inherit distutils-r1
  8. MY_PV="${PV/_beta/b}"
  9. DESCRIPTION="A system for controlling process state under UNIX"
  10. HOMEPAGE="http://supervisord.org/ https://pypi.python.org/pypi/supervisor"
  11. SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
  12. LICENSE="repoze ZPL BSD HPND GPL-2"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~x86"
  15. IUSE="doc test"
  16. # ALL versions of meld3 match to >=meld3-0.6.5
  17. RDEPEND="dev-python/meld3[${PYTHON_USEDEP}]
  18. dev-python/setuptools[${PYTHON_USEDEP}]"
  19. DEPEND="${RDEPEND}
  20. test? ( dev-python/mock[${PYTHON_USEDEP}] )
  21. doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
  22. S="${WORKDIR}/${PN}-${MY_PV}"
  23. python_compile_all() {
  24. # Somehow the test phase is called and run on invoking a doc build; harmless
  25. use doc && emake -C docs html
  26. }
  27. python_test() {
  28. esetup.py test
  29. }
  30. python_install_all() {
  31. newinitd "${FILESDIR}/init.d-r1" supervisord
  32. newconfd "${FILESDIR}/conf.d" supervisord
  33. use doc && local HTML_DOCS=( docs/.build/html/. )
  34. distutils-r1_python_install_all
  35. }