sxid-4.2-r1.ebuild 739 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools
  5. DESCRIPTION="suid, sgid file and directory checking"
  6. HOMEPAGE="http://freshmeat.net/projects/sxid"
  7. SRC_URI="http://linukz.org/download/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. RDEPEND="virtual/mailx"
  13. DEPEND=""
  14. DOCS=( docs/sxid.{conf,cron}.example )
  15. src_prepare() {
  16. # this is an admin application and really requires root to run correctly
  17. # we need to move the binary to the sbin directory
  18. sed -i s/bindir/sbindir/g source/Makefile.in || die
  19. eautoreconf
  20. }
  21. pkg_postinst() {
  22. elog "You will need to configure sxid.conf for your system using the manpage and example"
  23. }