system-config-printer-1.4.8.ebuild 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. PYTHON_COMPAT=( python2_7 )
  6. PYTHON_REQ_USE="xml"
  7. inherit gnome2 python-single-r1 systemd versionator
  8. MY_V="$(get_version_component_range 1-2)"
  9. DESCRIPTION="GNOME frontend for a Red Hat's printer administration tool"
  10. HOMEPAGE="http://cyberelk.net/tim/software/system-config-printer/"
  11. SRC_URI="http://cyberelk.net/tim/data/system-config-printer/${MY_V}/${P}.tar.xz"
  12. LICENSE="GPL-2"
  13. KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ppc64 ~sh ~sparc x86"
  14. SLOT="0"
  15. IUSE="doc gnome-keyring policykit"
  16. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  17. # Needs cups running, bug 284005
  18. RESTRICT="test"
  19. # Additional unhandled dependencies
  20. # gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
  21. # python samba client: smbc
  22. # selinux: needed for troubleshooting
  23. RDEPEND="
  24. ${PYTHON_DEPS}
  25. >=dev-libs/glib-2:2
  26. dev-libs/libxml2[python,${PYTHON_USEDEP}]
  27. dev-python/dbus-python[${PYTHON_USEDEP}]
  28. dev-python/pycairo[${PYTHON_USEDEP}]
  29. >=dev-python/pycups-1.9.60[${PYTHON_USEDEP}]
  30. dev-python/pycurl[${PYTHON_USEDEP}]
  31. dev-python/pygobject:3[${PYTHON_USEDEP}]
  32. net-print/cups[dbus]
  33. virtual/libusb:1
  34. >=virtual/udev-172
  35. x11-libs/gtk+:3[introspection]
  36. x11-libs/libnotify[introspection]
  37. x11-libs/pango[introspection]
  38. gnome-keyring? ( gnome-base/libgnome-keyring[introspection] )
  39. policykit? ( >=sys-auth/polkit-0.104-r1 )
  40. !app-admin/system-config-printer-common
  41. !app-admin/system-config-printer-gnome
  42. "
  43. DEPEND="${RDEPEND}
  44. app-text/docbook-xml-dtd:4.1.2
  45. >=app-text/xmlto-0.0.22
  46. dev-util/desktop-file-utils
  47. dev-util/intltool
  48. sys-devel/gettext
  49. virtual/pkgconfig
  50. doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )
  51. "
  52. APP_LINGUAS="ar as bg bn_IN bn br bs ca cs cy da de el en_GB es et fa fi fr gu
  53. he hi hr hu hy id is it ja ka kn ko lo lv mai mk ml mr ms nb nl nn or pa pl
  54. pt_BR pt ro ru si sk sl sr@latin sr sv ta te th tr uk vi zh_CN zh_TW"
  55. for X in ${APP_LINGUAS}; do
  56. IUSE="${IUSE} linguas_${X}"
  57. done
  58. # Bug 471472
  59. MAKEOPTS+=" -j1"
  60. pkg_setup() {
  61. python-single-r1_pkg_setup
  62. }
  63. src_configure() {
  64. local myconf
  65. # Disable installation of translations when LINGUAS not chosen
  66. if [[ -z "${LINGUAS}" ]]; then
  67. myconf="${myconf} --disable-nls"
  68. else
  69. myconf="${myconf} --enable-nls"
  70. fi
  71. gnome2_src_configure \
  72. --with-desktop-vendor=Gentoo \
  73. --with-udev-rules \
  74. $(systemd_with_unitdir) \
  75. ${myconf}
  76. }
  77. src_compile() {
  78. gnome2_src_compile
  79. use doc && emake html
  80. }
  81. src_install() {
  82. gnome2_src_install
  83. use doc && dohtml -r html/
  84. python_fix_shebang "${ED}"
  85. }