tmpwatch-2.11-r2.ebuild 722 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="Files which haven't been accessed are removed from specified directories"
  6. HOMEPAGE="https://fedorahosted.org/tmpwatch/"
  7. SRC_URI="https://fedorahosted.org/releases/t/m/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
  11. IUSE="selinux"
  12. RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
  13. DEPEND=""
  14. PATCHES=(
  15. "${FILESDIR}/${P}-boottime.patch"
  16. )
  17. src_compile() {
  18. emake AR="$(tc-getAR)"
  19. }
  20. src_install() {
  21. default
  22. dosbin tmpwatch
  23. doman tmpwatch.8
  24. exeinto /etc/cron.daily
  25. newexe "${FILESDIR}/${PN}.cron" "${PN}"
  26. }