xstow-1.0.1.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="replacement for GNU stow with extensions"
  6. HOMEPAGE="http://xstow.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/xstow/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE="ncurses"
  12. DEPEND="ncurses? ( sys-libs/ncurses )"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-ncurses.patch
  16. eautoreconf
  17. }
  18. src_configure() {
  19. econf $(use_with ncurses curses)
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install
  23. dodoc AUTHORS ChangeLog NEWS README TODO
  24. # create new STOWDIR
  25. dodir /var/lib/xstow
  26. # install env.d file to add STOWDIR to PATH and LDPATH
  27. doenvd "${FILESDIR}/99xstow" || die "doenvd failed"
  28. }
  29. pkg_postinst() {
  30. elog "We now recommend that you use /var/lib/xstow as your STOWDIR"
  31. elog "instead of /usr/local in order to avoid conflicts with the"
  32. elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264"
  33. elog "(regarding app-admin/stow, equally applicable to XStow) for"
  34. elog "more details on this change."
  35. elog "For your convenience, PATH has been updated to include"
  36. elog "/var/lib/bin."
  37. }