yadm-1.06.ebuild 821 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A dotfile manager for the config files in your home folder"
  5. HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
  6. SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="test"
  11. DOCS=( CHANGES CONTRIBUTORS README.md )
  12. DEPEND="
  13. test? (
  14. dev-util/bats
  15. dev-vcs/git
  16. )"
  17. RDEPEND="dev-vcs/git
  18. app-crypt/gnupg"
  19. src_compile() {
  20. emake yadm.md
  21. }
  22. src_test() {
  23. # 109_accept_encryption tests are interactive, thus fail. Skip them
  24. bats $(find test/ -type f -name '*.bats' -and -not -name '109_accept_encryption.bats') \
  25. || die "Tests failed"
  26. }
  27. src_install() {
  28. einstalldocs
  29. dobin "${PN}"
  30. doman "${PN}.1"
  31. }