afio-2.5.1.ebuild 673 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Makes cpio-format archives and deals gracefully with input data corruption"
  6. HOMEPAGE="http://members.chello.nl/k.holtman/afio.html"
  7. SRC_URI="http://members.chello.nl/k.holtman/${P}.tgz"
  8. LICENSE="Artistic LGPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
  11. IUSE=""
  12. src_prepare() {
  13. epatch "${FILESDIR}"/Makefile-r1.patch
  14. tc-export CC
  15. }
  16. src_install() {
  17. local i
  18. dobin afio
  19. dodoc ANNOUNCE-* HISTORY README SCRIPTS
  20. for i in 1 2 3 4; do
  21. docinto script$i
  22. dodoc script$i/*
  23. done
  24. doman afio.1
  25. }