pure-sfv-0.3-r1.ebuild 681 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="utility to test and create .sfv files and create .par files"
  6. HOMEPAGE="http://pure-sfv.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/pure-sfv/${PN}_${PV}_src.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~hppa ppc x86"
  11. IUSE=""
  12. RESTRICT="test"
  13. DEPEND=""
  14. S="${WORKDIR}"
  15. src_prepare() {
  16. sed -i Makefile -e "s:-Werror -O2 -g::"
  17. epatch "${FILESDIR}"/${P}-asneeded.patch
  18. }
  19. src_compile() {
  20. emake CC="$(tc-getCC)" || die "emake failed"
  21. }
  22. src_install() {
  23. dobin pure-sfv || die "dobin failed"
  24. dodoc ReadMe.txt
  25. }