stuffit-5.2.0.611.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. MY_P="stuffit520.611linux-i386"
  4. DESCRIPTION="Aladdin Software's StuffIt and StuffIt Expander"
  5. HOMEPAGE="http://www.stuffit.com/"
  6. SRC_URI="http://my.smithmicro.com/downloads/files/stuffit520.611linux-i386.tar.gz"
  7. LICENSE="Stuffit"
  8. SLOT="0"
  9. KEYWORDS="-* x86 amd64"
  10. IUSE=""
  11. RESTRICT="fetch strip"
  12. S="${WORKDIR}"
  13. INSTALLDIR="/opt/stuffit"
  14. pkg_nofetch() {
  15. einfo "Please download stuffit from"
  16. einfo "${SRC_URI}"
  17. einfo "and put the file in ${DISTDIR}"
  18. einfo
  19. einfo "Note that StuffIt requires registration within 30 days,"
  20. einfo "but StuffIt Expander is freeware."
  21. einfo
  22. }
  23. src_install() {
  24. # First do the binaries
  25. exeinto ${INSTALLDIR}/bin
  26. doexe bin/stuff
  27. doexe bin/unstuff
  28. # Now the registration binary
  29. exeinto ${INSTALLDIR}/extra
  30. doexe bin/register
  31. # Now the documentation
  32. docinto stuff
  33. dodoc doc/stuff/README
  34. dohtml doc/stuff/stuff.html
  35. docinto unstuff
  36. dodoc doc/unstuff/README
  37. dohtml doc/unstuff/unstuff.html
  38. # And now the man pages
  39. doman man/man1/*
  40. # Also add the executables to the path
  41. dodir /etc/env.d
  42. echo -e "PATH=${INSTALLDIR}/bin\nROOTPATH=${INSTALLDIR}/bin" > \
  43. "${D}"/etc/env.d/10stuffit
  44. }
  45. pkg_postinst() {
  46. elog
  47. elog "Reminder: StuffIt requires registration within 30 days."
  48. elog "The registration program is located in ${INSTALLDIR}/extra"
  49. elog
  50. elog "The binaries are named 'stuff' and 'unstuff'"
  51. elog
  52. }