unshield-1.4.ebuild 932 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="InstallShield CAB file extractor"
  6. HOMEPAGE="https://github.com/twogood/unshield"
  7. SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~hppa ~ppc x86"
  11. # OpenSSL (or LibreSSL) is detected at build time, and used to determine
  12. # whether or not a hand-rolled md5 implementation is used. The build
  13. # system prefers OpenSSL's implementation if it's available, and OpenSSL
  14. # is common enough, so we prefer it too. Since the dependency is
  15. # automagic (there's no way to hide it), we require Open/LibreSSL
  16. # unconditionally.
  17. IUSE="libressl"
  18. DEPEND="
  19. !libressl? ( dev-libs/openssl:0= )
  20. libressl? ( dev-libs/libressl:0= )
  21. sys-libs/zlib"
  22. RDEPEND="${DEPEND}"
  23. # Without this, the build fails looking for unshield_config.h.
  24. CMAKE_IN_SOURCE_BUILD=y