siege-3.0.6.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. #WANT_AUTOMAKE=1.9
  5. inherit eutils bash-completion-r1 libtool autotools
  6. DESCRIPTION="A HTTP regression testing and benchmarking utility"
  7. HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
  8. SRC_URI="http://www.joedog.org/pub/siege/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. KEYWORDS="amd64 hppa ~mips ppc x86 ~x64-macos"
  11. SLOT="0"
  12. IUSE="ssl"
  13. RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
  14. DEPEND="${RDEPEND}
  15. sys-devel/libtool"
  16. src_prepare() {
  17. # bundled macros break recent libtool
  18. sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
  19. rm *.m4 || die "failed to remove bundled macros"
  20. eautoreconf
  21. }
  22. src_configure() {
  23. local myconf
  24. use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
  25. econf ${myconf}
  26. }
  27. src_install() {
  28. make DESTDIR="${D}" install
  29. dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
  30. doc/siegerc doc/urls.txt
  31. newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
  32. }
  33. pkg_postinst() {
  34. echo
  35. elog "An example ~/.siegerc file has been installed in"
  36. elog "${EPREFIX}/usr/share/doc/${PF}/"
  37. }