stress-1.0.4-r1.ebuild 540 B

1234567891011121314151617181920212223
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic
  5. MY_P=${PN}-${PV/_/}
  6. DESCRIPTION="Imposes stressful loads on different aspects of the system"
  7. HOMEPAGE="http://people.seas.harvard.edu/~apw/stress"
  8. SRC_URI="http://people.seas.harvard.edu/~apw/stress/${MY_P}.tar.gz -> ${MY_P}-r1.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86"
  12. IUSE="static"
  13. S=${WORKDIR}/${MY_P}
  14. src_prepare() {
  15. use static && append-ldflags -static
  16. }