sysbench-1.0.3.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. DESCRIPTION="System performance benchmark"
  5. HOMEPAGE="https://github.com/akopytov/sysbench"
  6. SRC_URI="https://github.com/akopytov/sysbench/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="GPL-2+"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="aio mysql postgres test"
  11. RDEPEND="aio? ( dev-libs/libaio )
  12. mysql? ( virtual/libmysqlclient )
  13. postgres? ( dev-db/postgresql:= )"
  14. DEPEND="${RDEPEND}
  15. app-editors/vim-core
  16. dev-lang/luajit:=
  17. dev-libs/concurrencykit
  18. dev-libs/libxslt
  19. sys-devel/libtool:=
  20. virtual/pkgconfig
  21. test? ( dev-util/cram )"
  22. src_prepare() {
  23. default
  24. sed -i -e "/^htmldir =/s:=.*:=/usr/share/doc/${PF}/html:" doc/Makefile.am || die
  25. # remove bundled libs
  26. rm -r third_party/luajit/luajit third_party/concurrency_kit/ck || die
  27. ./autogen.sh || die
  28. }
  29. src_configure() {
  30. local myeconfargs=(
  31. $(use_enable aio aio)
  32. $(use_with mysql mysql)
  33. $(use_with postgres pgsql)
  34. --without-attachsql
  35. --without-drizzle
  36. --without-oracle
  37. --with-system-luajit
  38. --with-system-ck
  39. )
  40. econf "${myeconfargs[@]}"
  41. }
  42. src_test() {
  43. emake check test
  44. }