sysbench-1.0_pre20161017.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. GITHUB_REV="48124f838b00ff83a044fbf046a9d8d0b1602d90"
  5. MY_PN="${PN}-${GITHUB_REV}"
  6. DESCRIPTION="System performance benchmark"
  7. HOMEPAGE="https://github.com/akopytov/sysbench"
  8. SRC_URI="https://github.com/akopytov/sysbench/archive/${GITHUB_REV}.tar.gz -> ${MY_PN}.tar.gz"
  9. LICENSE="GPL-2+"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="aio lua mysql postgres test"
  13. RDEPEND="aio? ( dev-libs/libaio )
  14. lua? ( dev-lang/lua:= )
  15. mysql? ( virtual/libmysqlclient )
  16. postgres? ( dev-db/postgresql:= )"
  17. DEPEND="${RDEPEND}
  18. sys-devel/libtool:=
  19. dev-libs/libxslt
  20. test? ( dev-util/cram )"
  21. REQUIRED_USE="
  22. mysql? ( lua )
  23. postgres? ( lua )"
  24. S="${WORKDIR}/${MY_PN}"
  25. src_prepare() {
  26. default
  27. sed -i -e "/^htmldir =/s:=.*:=/usr/share/doc/${PF}/html:" doc/Makefile.am || die
  28. ./autogen.sh || die
  29. }
  30. src_configure() {
  31. local myeconfargs=(
  32. $(use_enable aio aio)
  33. $(use_with lua lua)
  34. $(use_with mysql mysql)
  35. $(use_with postgres pgsql)
  36. --without-attachsql
  37. --without-drizzle
  38. --without-oracle
  39. )
  40. econf "${myeconfargs[@]}"
  41. }
  42. src_test() {
  43. emake check test
  44. }