bin2iso-19b-r2.ebuild 727 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="converts RAW format (.bin/.cue) files to ISO/WAV format"
  5. HOMEPAGE="http://users.andara.com/~doiron/bin2iso/"
  6. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  7. LICENSE="public-domain"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
  10. IUSE=""
  11. DEPEND=""
  12. S=${WORKDIR}/${PN}
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. edos2unix *.c
  17. epatch "${FILESDIR}"/${P}-sanity-checks.patch
  18. }
  19. src_compile() {
  20. $(tc-getCC) bin2iso19b_linux.c -o ${PN} ${CFLAGS} ${LDFLAGS} || die "compile failed"
  21. }
  22. src_install() {
  23. dobin ${PN} || die "dobin failed"
  24. dodoc readme.txt
  25. }