brasero-3.12.1-r1.ebuild 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME2_LA_PUNT="yes"
  6. inherit eutils gnome2
  7. DESCRIPTION="CD/DVD burning application for the GNOME desktop"
  8. HOMEPAGE="https://wiki.gnome.org/Apps/Brasero"
  9. LICENSE="GPL-2+ CC-BY-SA-3.0"
  10. SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
  11. IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  13. COMMON_DEPEND="
  14. >=dev-libs/glib-2.29.14:2
  15. >=x11-libs/gtk+-3:3[introspection?]
  16. media-libs/gstreamer:1.0
  17. media-libs/gst-plugins-base:1.0
  18. >=dev-libs/libxml2-2.6:2
  19. >=x11-libs/libnotify-0.6.1:=
  20. media-libs/libcanberra[gtk3]
  21. x11-libs/libICE
  22. x11-libs/libSM
  23. introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
  24. libburn? (
  25. >=dev-libs/libburn-0.4:=
  26. >=dev-libs/libisofs-0.6.4:= )
  27. nautilus? ( >=gnome-base/nautilus-2.91.90 )
  28. playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
  29. tracker? ( >=app-misc/tracker-0.12:0= )
  30. "
  31. RDEPEND="${COMMON_DEPEND}
  32. media-libs/gst-plugins-good:1.0
  33. media-plugins/gst-plugins-meta:1.0
  34. x11-themes/hicolor-icon-theme
  35. css? ( media-libs/libdvdcss:1.2 )
  36. !libburn? (
  37. app-cdr/cdrdao
  38. app-cdr/dvd+rw-tools
  39. virtual/cdrtools )
  40. mp3? (
  41. media-libs/gst-plugins-ugly:1.0
  42. media-plugins/gst-plugins-mad:1.0 )
  43. packagekit? ( app-admin/packagekit-base )
  44. "
  45. DEPEND="${COMMON_DEPEND}
  46. >=dev-util/intltool-0.50
  47. dev-util/itstool
  48. >=dev-util/gtk-doc-am-1.12
  49. sys-devel/gettext
  50. virtual/pkgconfig
  51. test? ( app-text/docbook-xml-dtd:4.3 )
  52. "
  53. # eautoreconf deps
  54. # app-text/yelp-tools
  55. # gnome-base/gnome-common
  56. PDEPEND="gnome-base/gvfs"
  57. src_prepare() {
  58. # https://bugzilla.gnome.org/show_bug.cgi?id=744916
  59. epatch "${FILESDIR}"/${PN}-3.12.1-libdvdcss.patch
  60. gnome2_src_prepare
  61. }
  62. src_configure() {
  63. DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
  64. gnome2_src_configure \
  65. --disable-caches \
  66. $(use_enable !libburn cdrtools) \
  67. $(use_enable !libburn cdrkit) \
  68. $(use_enable !libburn cdrdao) \
  69. $(use_enable !libburn growisofs) \
  70. $(use_enable introspection) \
  71. $(use_enable libburn libburnia) \
  72. $(use_enable nautilus) \
  73. $(use_enable playlist) \
  74. $(use_enable tracker search)
  75. }