cdemu-daemon-3.0.4.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit cmake-utils eutils
  5. DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
  6. HOMEPAGE="http://cdemu.org"
  7. SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
  8. LICENSE="GPL-2+"
  9. SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
  10. KEYWORDS="amd64 ~hppa x86"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/glib-2.32:2
  13. >=dev-libs/libmirage-${PV}:=
  14. >=media-libs/libao-0.8.0:=
  15. sys-apps/dbus
  16. >=sys-fs/vhba-20130607"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. src_prepare() {
  20. DOCS="AUTHORS README"
  21. cmake-utils_src_prepare
  22. }
  23. pkg_postinst() {
  24. elog "You will need to load the vhba module to use cdemu devices:"
  25. elog " # modprobe vhba"
  26. elog "To automatically load the vhba module at boot time, edit your"
  27. elog "/etc/conf.d/modules file."
  28. if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
  29. elog
  30. elog "${PN} no longer installs an init.d service; instead, it is"
  31. elog "automatically activated when needed via dbus."
  32. elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
  33. fi
  34. }