gcdemu-3.0.0.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. PLOCALES="no sl sv"
  6. # cmake-utils after gnome2, to make sure cmake-utils is used for building
  7. inherit gnome2 cmake-utils l10n python-single-r1
  8. DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
  9. HOMEPAGE="http://cdemu.org/"
  10. SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
  11. LICENSE="GPL-2+"
  12. SLOT="0"
  13. KEYWORDS="amd64 x86"
  14. IUSE=""
  15. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  16. RDEPEND="${PYTHON_DEPS}
  17. app-cdr/cdemu-daemon:0/7
  18. >=dev-libs/glib-2.28:2
  19. dev-libs/gobject-introspection
  20. dev-python/pygobject:3[${PYTHON_USEDEP}]
  21. gnome-base/librsvg:2
  22. sys-apps/dbus
  23. x11-libs/gdk-pixbuf[introspection]
  24. x11-libs/gtk+:3[introspection]
  25. x11-libs/libnotify[introspection]"
  26. DEPEND="${COMMON_DEPEND}
  27. dev-util/desktop-file-utils
  28. >=dev-util/intltool-0.21
  29. sys-devel/gettext
  30. virtual/pkgconfig"
  31. pkg_setup() {
  32. python-single-r1_pkg_setup
  33. }
  34. src_prepare() {
  35. python_fix_shebang src/gcdemu
  36. }
  37. src_configure() {
  38. DOCS="AUTHORS README"
  39. local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
  40. cmake-utils_src_configure
  41. }
  42. src_install() {
  43. cmake-utils_src_install
  44. # Build system doesn't respect LINGUAS, and changing list of installed
  45. # translations requires error-prone editing of CMakeLists.txt
  46. rm_po() {
  47. rm -r "${ED}"/usr/share/locale/$1 || die
  48. ls "${ED}"/usr/share/locale/* &> /dev/null || rmdir "${ED}"/usr/share/locale || die
  49. }
  50. l10n_for_each_disabled_locale_do rm_po
  51. }