isomaster-1.3.11.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils fdo-mime toolchain-funcs
  5. DESCRIPTION="Graphical CD image editor for reading, modifying and writing ISO images"
  6. HOMEPAGE="http://littlesvr.ca/isomaster"
  7. SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~x86-fbsd"
  11. IUSE="nls"
  12. RDEPEND=">=dev-libs/iniparser-3.0.0:0
  13. x11-libs/gtk+:2"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig
  16. nls? ( >=sys-devel/gettext-0.19.1 )" # bug 512448
  17. pkg_setup() {
  18. myisoconf=(
  19. DEFAULT_EDITOR=leafpad
  20. MYDOCPATH=/usr/share/doc/${PF}/bkisofs
  21. USE_SYSTEM_INIPARSER=1
  22. PREFIX=/usr
  23. )
  24. use nls || myisoconf+=( WITHOUT_NLS=1 )
  25. }
  26. src_prepare() {
  27. epatch "${FILESDIR}"/${P}-make-install.patch
  28. epatch "${FILESDIR}"/${PN}-1.3.9-iniparser-3.0.0.patch #399629
  29. rm -R iniparser-2.17 || die
  30. }
  31. src_configure() { :; } #274361
  32. src_compile() {
  33. tc-export CC
  34. emake "${myisoconf[@]}"
  35. }
  36. _apply_linguas() {
  37. mv "${D}"/usr/share/locale{,_ALL} || die
  38. dodir /usr/share/locale || die
  39. for lingua in ${LINGUAS}; do
  40. [[ -d "${D}"/usr/share/locale_ALL/${lingua} ]] || break
  41. mv "${D}"/usr/share/{locale_ALL/${lingua},locale/} || die
  42. done
  43. rm -R "${D}"/usr/share/locale_ALL || die
  44. }
  45. src_install() {
  46. emake "${myisoconf[@]}" DESTDIR="${D}" install
  47. dodoc {CHANGELOG,CREDITS,README,TODO}.TXT *.txt
  48. use nls && _apply_linguas # bug 402679, bug 512448
  49. }
  50. pkg_postinst() {
  51. fdo-mime_desktop_database_update
  52. }
  53. pkg_postrm() {
  54. fdo-mime_desktop_database_update
  55. }